Level Money is taking proactive steps to ensure that its users are as secure as possible by requiring that they update to iOS version 7.0.6, which contains Apple’s new security patch. According to Level Money’s blog it was the responsible thing to do, even though it wasn’t responsible for the breach.

“Even though this is not a vulnerably in the Level system, we knew we had to do everything in our power prevent exposure of the sensitive information our members trust us with. Last night, we implemented a requirement that Level members update to iOS version 7.0.6 in order to continue using the app. Version 7.0.5 is inherently insecure, and data on that iOS version cannot be protected. Members that update to the latest version should be able to resume use of Level Money without any further interruption. However, we know we are far from the only app entrusted with sensitive information, which is why we are calling on all other app developers — particularly those handling banking and payment information —to implement similar measures. Apps handling sensitive information have a responsibility to respond quickly to this type of exposure. Users must be required to update their iOS version if we are to uphold our promise to protect the information which we are entrusted with.”

Level Money is available for free on the App Store

source: Level Money Blog